From: Mauricio Fernandez Date: 2007-04-05T19:31:06+09:00 Subject: Re: ruby-services -- unable to start fastri service On Fri, Feb 09, 2007 at 12:10:07PM +0900, bbiker wrote: > I have just done a complete new installation of ruby-services. I have > all the required gems. > > I have installed the fastri service as well as the gem service. > > However, I cannot start the fastri service. > > This is the response I get: > > C:\Documents and Settings\Owner>fastrictl -s > C:/ruby/bin/fastrictl.rb:68:in `start': The service did not respond to > the start or control request in a timely fashion. > (Win32::ServiceError) > from C:/ruby/bin/fastrictl.rb:68 > > I have no problem with the gem service. > > C:\Documents and Settings\Owner>gemctl -s > One moment, start pending > Gem Server service started > > I am running fastri 0.3.0 and it was installed from the tarball. I don't really know anything about ruby-services (or win32 for the matter), but maybe I can help you with FastRI's part. If fastri-server -b is indexing the stdlib/your gems correctly, you can also use qri which works very much like fri, the only difference being that it accesses the local index directly without relying on the DRb service provided by fastri-server (it's a bit slower too, but still much faster than plain RI, <1s vs. >10s for typical queries). Also, does the fastri-server (+fri) work when launched manually? -- Mauricio Fernandez - http://eigenclass.org - singular Ruby ** Latest postings ** The Neo-Rails controversy and a language generator http://eigenclass.org/hiki/language-generator Rails on 1.9: first benchmarks, YARV exposed to non-synthetic tests http://eigenclass.org/hiki/non-synthetic-benchmarks-for-yarv