From: Josef 'Jupp' Schugt Date: 2007-03-26T08:23:40+09:00 Subject: Re: Suggestion: swap name of "puts" and "print" and rename "puts" to "put_s" --------------enig67C7EB88EE1D7A9B7F502EEF Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: quoted-printable > I'd like to suggest that the functionality of the names "puts" and > "print" should be swapped so that "print" automatically sends a newline= > character and "puts" doesn't. Note that Ruby is written in C and that C's "puts" does return carriage while its "printf" does not. Also note that POLS (principle of least surprise) precisely taken is POLS2YM (principle of least surprise to Yukikiro Matsumoto). Your suggestion seems to violate this principle. But now that you bring up the subject: What about adding a consistent definition of write and write_ln? This would only change very little and - which IMHO is important - does not unbearable introduce version incompatibility. Changing the name of the basic output functions would surely break literally every Ruby program. In other words: The cost of changing them is much larger than the cost of living with this kind of Altlast ("legacy" is one possible translation for this word but it has quite a lot of other meanings as well, see dict.leo.org or similar). Josef 'Jupp' Schugt --=20 Blog available at http://www.mynetcologne.de/~nc-schugtjo/blog/ PGP key with id 6CC6574F available at http://wwwkeys.de.pgp.net/ --------------enig67C7EB88EE1D7A9B7F502EEF Content-Type: application/pgp-signature; name="signature.asc" Content-Description: OpenPGP digital signature Content-Disposition: attachment; filename="signature.asc" -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.7 (GNU/Linux) iD8DBQFGBwR0rhv7B2zGV08RAmq+AJ9crB2cx7UPRc6Xj+wI4ejEPkTeyACfTlZk RxxU/OzQXdOQRFZFwXiOX8o= =x+eo -----END PGP SIGNATURE----- --------------enig67C7EB88EE1D7A9B7F502EEF--