From: Devin Mullins Date: 2007-03-25T02:17:09+09:00 Subject: Re: Suggestion: swap name of "puts" and "print" and rename "puts" to "put_s" Michael Brooks wrote: > I'd like to suggest that the functionality of the names "puts" and > "print" should be swapped so that "print" automatically sends a newline > character and "puts" doesn't. Hrm... That breaks the "Huffman-encoding" of the current scheme. #puts is by far the more used method, and so it's shorter. Maybe call it #put or #say, and then pick a longer name for the feedless version (maybe stick with #print, though something that acknowledged its correlation with #put would be nice). alias put puts alias put_on print # short for put_on_the_same_line alias eminence_front put_on # look it up undef puts; undef print ? ** Devin * #p and #y are excused -- one-character names are illegibly short, so they can be reserved for little debug functions where terseness (tersion?) is of primary import. ** Not a serious proposition, you turd.