From: Ruby Admirer Date: 2007-03-23T18:07:14+09:00 Subject: Re: About class methods visibility (public/private) --0-549184302-1174640816=:19871 Content-Type: text/plain; charset=iso-8859-1 Content-Transfer-Encoding: 8bit >Yukihiro Matsumoto wrote: >There's no need for new methods. private_class_method and others are >utility method for people who really love the term 'class methods'. I agree. But as I indicated with a previous post, there is one such utility method that is currently missing. There is no protected_class_method for making a class method protected. In addition, the current naming of the 2 existing utility methods (private_class_method and public_class_method) is very confusing. Please take a look at the post on this thread from Gavin who "interprets" my request and states more clearly the naming issue. So I do not request a lot of fresh new methods. I just request one new method and a renaming of 2 existing methods. --------------------------------- Don't pick lemons. See all the new 2007 cars at Yahoo! Autos. --0-549184302-1174640816=:19871--