From: Phrogz Date: 2007-03-23T01:35:06+09:00 Subject: Re: About class methods visibility (public/private) On Mar 22, 10:21 am, "Phrogz" wrote: > On Mar 22, 2:53 am, Yukihiro Matsumoto wrote: > > > | I would prefer something like class_private, class_protected, class_public. > > > What do you confuse with what? For me, class_private etc. mean nothing. I used to say to budding programmers "properties should be named as nouns, methods should be named as verbs". With Ruby craftily making all public access go through methods, I'd have to revise that to something like: "Methods with no side-effects whose purpose is to return a value should be named as nouns. Methods whose purpose is to cause a side effect should be named as verbs or imperatives." So my suggestion would be to rename the two methods in question as something like: Module#public_class_method => Module#make_methods_public => Module#publicize_methods Module#private_class_method => Module#make_methods_private => Module#privatize_methods (I'm not sure if I like the method name to use "methods" or "method", given that it can take more than one argument.)