From: David Alan Black Date: 2001-11-03T05:02:50+09:00 Subject: [ruby-talk:24195] Re: __FILE__ == $0 refactored in Ruby? Hello -- On Sat, 3 Nov 2001, Morris, Chris wrote: > I see __FILE__ == $0 frequently. Is there a more readable form of this > already in Ruby? -- something like: > > def fileExecutedIsThisFile > __FILE__ == $0 > end I don't think I know of a more readable version. Did you want to suggest one? :-) (I know, I know.) Have a look at the thread starting at: Subject: [ruby-talk:21504] Replacement for __FILE__ == $0 for some earlier discussion of this. David -- David Alan Black home: dblack@candle.superlink.net work: blackdav@shu.edu Web: http://pirate.shu.edu/~blackdav