From: "Morris, Chris" Date: 2001-11-03T04:38:33+09:00 Subject: [ruby-talk:24192] __FILE__ == $0 refactored in Ruby? I see __FILE__ == $0 frequently. Is there a more readable form of this already in Ruby? -- something like: def fileExecutedIsThisFile __FILE__ == $0 end Chris Morris chris.morris@snelling.com