From: James Edward Gray II Date: 2007-02-22T01:06:02+09:00 Subject: Re: creating a hash key with a variable name? On Feb 21, 2007, at 9:55 AM, terry wrote: > Is it possible that I could do the following, if so what is the > correct syntax? > > aHash = Hash.new > aString = "BasketballTeam" > aHash[aString] => "Bulls" Drop the greater than symbol in the last line: aHash[aString] = "Bulls" And sense we are talking, allow me to explain the variable naming conventions for Ruby. ;) We prefer to use snake_case for variable and method names and save the CamelCase for class and module names. Doing that, I would rewrite your code as: a_hash = Hash.new a_string = "BasketballTeam" a_hash[a_string] = "Bulls" Of course, "a_hash" and "a_string" don't really tell us much, so let's go a step further and try to pick variable names that inform us of what we are working with: teams = Hash.new team_type = "BasketballTeam" teams[team_type] = "Bulls" I think that reads a lot better, but you be the judge. Hope that helps. James Edward Gray II