From: Trans Date: 2007-01-25T22:03:27+09:00 Subject: Re: New Singleton Class Word-of-the-Month ;-) On Jan 25, 7:48 am, Daniel Schierbeck wrote: > Perhaps a bit too long, although it's more concise than `class << self; > self; end'. I quite favor `behavior', since that's really what it is; a > container for an object's behavior. Right. that's sort of the reasoning I think Dave Thomas was suggesting. Howver "behavior" is a little too generic b/c the regular class of an object also defines behavior. Although it is even longer, that's why I felt #customization was a better fit, with #customize as a nice shortcut for customization.class_eval. T.