From: Luke Ivers Date: 2007-01-24T02:17:33+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' On Wed, 24 Jan 2007 02:10:08 +0900 "Phrogz" wrote: > dblack@wobblini.net wrote: > > On Wed, 24 Jan 2007, Pit Capitain wrote: > [snip] > > > So, I would say that after > > > > > > m = a.method(:x) > > > > > > the object a has at least partly acted as a receiver. > > > > > > David, could you live with that? :-) > > > > If I can send people to you when they ask for an explanation of the > > double meaning :-) > > FWIW, it totally makes sense to me for "m.receiver" to return the > object a in the above. Whether it's a Method instance, or a MethodData > instance, we're asking questions about the method itself...which > includes "what will happen when I call this method?". Given that, and > given that I agree with Ara's point about future references, I'm happy > to call the #probable_future_receiver just #receiver. It's the only > receiver that the method knows about at the time of asking, anyhow > (right?). > > To me (whom no one knows, or probably cares about), calling it target would imply that it could be changed... calling it receiver correctly implies the context of immutability. -- Luke Ivers