From: schneik@... Date: 2000-04-03T23:43:47-05:00 Subject: [ruby-talk:02357] Re: Function of Array.filter surprises me Matz writes: # But if you guys feel OK for collect!/map!, I sould seriously consider # renaming `filter'. I'd prefer not changing filter (except maybe make it an alias for map!) for the time being just to minimize the chances of breaking running code. (But of course I would want filter removed from Ruby 3000 :-) For the time being, I would like to have map/map!, collect/collect!, select/select!, and grep/grep!. Conrad Schneiker (This note is unofficial and subject to improvement without notice.)