From: Yukihiro Matsumoto Date: 2007-01-23T09:47:03+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' Hi, In message "Re: Minor Change Proposal for Classes 'Object' and 'Method'" on Tue, 23 Jan 2007 09:14:28 +0900, dblack@wobblini.net writes: |I don't know, in terms of the other languages. I don't think it's |exactly analogous, though. It's really a bound object, so |bound_object would probably be the most straightforward. The term 'bound_object' is not suitable for the Method object model in my brain. I want to retrieve the object corresponding to self in that method. Among your suggestions, "target" is better than bound_object. But I still fond of 'receiver'. |I've also started thinking about the idea of a MethodData class... but |it's pretty unformulated. Hmm, I am looking forward. matz.