From: dblack@... Date: 2007-01-23T09:14:28+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' Hi -- On Mon, 22 Jan 2007, Yukihiro Matsumoto wrote: > Hi, > > In message "Re: Minor Change Proposal for Classes 'Object' and 'Method'" > on Mon, 22 Jan 2007 20:30:38 +0900, dblack@wobblini.net writes: > > |I've always found it very helpful (for myself and others) to keep the > |whole sequence very visible (message sending, method lookup, method > |execution), and I think that using "receiver" as an attribute of a > |method object does a short-circuit in the terminology that makes it > |harder to explain and understand. > > Hmm, OK, what terminology do you use for "this" (or self) in languages > without message passing model (e.g. C++ or Java)? That should be the > appropriate term for it. I use "receiver" for them too, since I have > strong Smalltalk influence. I don't know, in terms of the other languages. I don't think it's exactly analogous, though. It's really a bound object, so bound_object would probably be the most straightforward. I've also started thinking about the idea of a MethodData class... but it's pretty unformulated. David -- Q. What is THE Ruby book for Rails developers? A. RUBY FOR RAILS by David A. Black (http://www.manning.com/black) (See what readers are saying! http://www.rubypal.com/r4rrevs.pdf) Q. Where can I get Ruby/Rails on-site training, consulting, coaching? A. Ruby Power and Light, LLC (http://www.rubypal.com)