From: Yukihiro Matsumoto Date: 2007-01-22T21:51:52+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' Hi, In message "Re: Minor Change Proposal for Classes 'Object' and 'Method'" on Mon, 22 Jan 2007 20:30:38 +0900, dblack@wobblini.net writes: |I've always found it very helpful (for myself and others) to keep the |whole sequence very visible (message sending, method lookup, method |execution), and I think that using "receiver" as an attribute of a |method object does a short-circuit in the terminology that makes it |harder to explain and understand. Hmm, OK, what terminology do you use for "this" (or self) in languages without message passing model (e.g. C++ or Java)? That should be the appropriate term for it. I use "receiver" for them too, since I have strong Smalltalk influence. matz.