From: Yukihiro Matsumoto Date: 2007-01-22T09:02:55+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' Hi, In message "Re: Minor Change Proposal for Classes 'Object' and 'Method'" on Mon, 22 Jan 2007 02:03:35 +0900, dblack@wobblini.net writes: |That's all correct, but the word "receiver" doesn't communicate it to |me. Given this: | | m = a.method(:x) | |I do not consider it optimal to describe a as m's "receiver". It's a |re-definition of the term, and I think it would lead to confusion. "a.method(:x)" looks up a method corresponding message :x, so that we can invoke the method later. It is more accurate to call it "target" or "bound_method", as you pointed. But I feel like there's a convention to call the target (or self) of a method as a "receiver" in OOP context. Given that context, it's natural to call "a" receiver. matz.