From: Robert Dober Date: 2007-01-22T03:36:22+09:00 Subject: Re: Hash pairs at? ------=_Part_180637_33354756.1169404579942 Content-Type: text/plain; charset=ISO-8859-1; format=flowed Content-Transfer-Encoding: 7bit Content-Disposition: inline On 1/21/07, Trans wrote: > > > Robert Dober wrote: > > > Think I still prefer the readability of #pairs_at however. But the > above is good to have too. > > T. > > > The more I think about it the more I like the Smalltalk approach, the syntactic sugar kind of spoils us, ( I remember how happy I was about C++ in the first please because I could write whatever_object + another_object well I was young and stupid than, now of course I am older ;). It is really your posts who brought it up, it is so natural to want to have consistent notation. But sometimes I really think Ruby would be better a language without Array#<< Proc#[] etc. etc Why is there not a Array#>> for #pop, these are very reasonable questions a new Ruby user will ask!. If we would have one way to call a proc, one way to push to an array, things would be simpler. I *still* agree that now, gotten used to it, << is very, very readable (I *never* use #push), but I am starting to wonder if I am not mistaken? In that spirit I guess #pairs_at is really much more readable, we should use Programming Jargon, not Ruby Jargon (although it gives this warm fuzzy feeling, I agree!!!!). Cheers Robert -- "The best way to predict the future is to invent it." - Alan Kay ------=_Part_180637_33354756.1169404579942--