From: mengx@... Date: 2000-04-03T15:24:00-04:00 Subject: [ruby-talk:02352] Re: Function of Array.filter surprises me > > I have to admit `filter' is not a best name; some proposed `collect!', > but I don't feel it's not collecting anything. > > > matz. Would convert/convert! or transform/transform! be better that collect/filter? Of course they could mean something like "to_s", but in iterator context, I will not be confused. -Ted