From: Daniel Berger Date: 2007-01-21T12:23:23+09:00 Subject: Re: problem in win32-service ... or ... what ? BENI wrote: > Daniel Berger wrote: > > >> Also, be sure to put your require's within the begin block. The last >> time someone reported a similar problem it turned out they were >> require'ing a custom library that wasn't in their $LOAD_PATH. I wonder >> if the same thing is happening with yahootickerpull.rb. >> >> Dan > > Thanks for your reply > > > I did it as you suggested ... the yahootickerservice.rb now has the > require statements in begin block. > > so now i get the log file also that shows exactly what you guessed > > ....."Daemon failure: no such file to load -- yahootickerpull" > > > so any lead ...... how do i include require yahootickerpull correctly > ? You either install yahootickerpull.rb in ruby sitelibdir, or you modify $LOAD_PATH to point to wherever your yahootickerpull.rb file lives. Regards, Dan