From: "Wolfgang Nádasi-Donner" Date: 2007-01-21T07:25:08+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' dblack@wobblini.net schrieb: > I'll add that, though it's a subtle point, I don't think that objects > receive methods. They receive messages, and act on the basis of those > messages (execute a like-named method or method_missing, or raise an > exception). This means, that the object bound into a Method object should be named something like "caller". The message receiving and searching for an appropriate method ist done by the object during the processing of the "method" message. The method found then will be bound to the message object, and later exactly this method will be called by the object when using the message object. Wolfgang N�dasi-Donner