From: Robert Klemme Date: 2007-01-21T02:40:08+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' On 19.01.2007 19:33, Yukihiro Matsumoto wrote: > Wolfgang's proposal can be divided into three methods. > > #receiver that returns the bound object of the method object. > #name that returns the name of the method object. > and a method that returns the class which holds the method. > > Does anybody have good name candidate for the last one? I have > already implemented the first two methods in the local copy of the > repository. I opt for "defining_class", because this precisely states what it returns. Some might find it a bit much of typing but I think we have much worse cases in Ruby (attr_accessor for example, which is much more often used). If someone can come up with an equally clear name which is shorter, that's fine with me. Kind regards robert