From: Yukihiro Matsumoto Date: 2007-01-20T03:33:57+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' Hi, In message "Re: Minor Change Proposal for Classes 'Object' and 'Method'" on Sat, 20 Jan 2007 01:52:36 +0900, Yukihiro Matsumoto writes: |Why object_id? Isn't it more useful to return the receiver itself, |e.g. | | myhi.receiver # => # | |? Wolfgang's proposal can be divided into three methods. #receiver that returns the bound object of the method object. #name that returns the name of the method object. and a method that returns the class which holds the method. Does anybody have good name candidate for the last one? I have already implemented the first two methods in the local copy of the repository. matz.