From: Kalman Noel Date: 2007-01-20T03:05:08+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' Yukihiro Matsumoto: > And why should method_name return combination of class name and method > name? I think the method_name should return the method name only > ("hi" for this case). I agree here. Furthermore I think that #name would be a better name, in analogy to Module#name. Kalman