From: "Wolfgang Nádasi-Donner" Date: 2007-01-20T02:45:09+09:00 Subject: Re: Minor Change Proposal for Classes 'Object' and 'Method' Yukihiro Matsumoto schrieb: > Why object_id? Isn't it more useful to return the receiver itself, > e.g. > > myhi.receiver # => # > > ? > > And why should method_name return combination of class name and method > name? I think the method_name should return the method name only > ("hi" for this case). It may be useful to implement separate method > to get a class that holds the method. I agree, because I'm only interested in the information at all. If you find a better format or better way to present it, its fine. One question is open for 'myhi.receiver # => #'. First, the format requires a pattern matching on the result, if the object-id ist needed only. May be two seperate methods are better, as you suggested for 'method_name'. In additon, a format for the seperate method, that returns information about the class that holds the method, may be complicated for singleton methods. An example is '#.private_hi>'. Wolfgang N�dasi-Donner (WoN�Do)