From: Trans Date: 2007-01-12T11:15:08+09:00 Subject: Re: a most undangerous Hash#store! Mauricio Fernandez wrote: > Yes, that's the idea ("more regular behavior"), but as Robert said, a > predicate method with side-effects seems _very_ dangerous (yes, store!? would > be more accurate :). > > So it might make sense to name it e.g. #store_once, with the above > semantics. Returning the value that was passed to the method makes little > sense: it doesn't provide any information we didn't have to being with. i agree. i will use that semantic but with a different name. after further consideration I thought of: insert(key,value) i think its apt. argree? t.