From: Evan Weaver Date: 2007-01-08T18:06:43+09:00 Subject: Re: Little Things Regarding 'funcall', I would rather support a 'send'-derived word which reflects the message-passing nature of what is really going on. Also, my brain reads 'funcall' most intuitively as 'FUNCtion ALL'. However I think the tradition of ! modifying the receiver makes 'send!' for private methods not good. I don't have a better suggestion, though. Regarding overriding 'send', I don't think that any method is too important to be overridden. Perhaps '__send' to always call the original version would be ok, but the idea of permanently disallowing some operation because it's "important" doesn't sit well with me. If I want to break Ruby, I want it to graciously break, instead of saying 'No'. Regarding the name of singleton classes, I think 'eigenclass' is ok. I am partial to 'shadow_class', because the singleton class shadows the real class. I would like to be allowed to instantiate new objects from them, as a sort of backhanded prototyping. Evan Weaver -- Posted via http://www.ruby-forum.com/.