From: "Peña, Botp" Date: 2007-01-08T13:13:12+09:00 Subject: Re: a most undangerous Hash#store! Trans [mailto:transfire@gmail.com] : # # As with #store but adds the key/value pair # # only if the key isn't already in the hash. just a suggestion: *not another new method name (since we're still updating/merging, right?). just add an option --if possible ie merge :nodup update :nodup merge require => :nodup update require => :nodup merge :safe update :safe merge require => :safe update require => :safe