From: William James Date: 2007-01-08T12:50:11+09:00 Subject: Re: a most undangerous Hash#store! Trans wrote: > Hi-- > > Think I need a better name for this method. It is anything but > dangerous. Any ideas? > > # As with #store but adds the key/value pair > # only if the key isn't already in the hash. > > def store!(key, value) > unless key?(key) > store(key,value) > return value > end > end > > T. new_item