From: Jason Vogel Date: 2006-12-07T14:45:09+09:00 Subject: Re: Difference between nil? vs. (variable != nil)... I found 'return "" if product_coverage.external_description.nil?' as a source sample somewhere, and I liked the readability factor. It seemed very "Ruby-ish" to a PowerBuilder/Java/C# developer :-). In the end, I'm trying to figure out my "best practice" for iterating over an array of objects. I'll happily take any suggestions. Thanks, Jason On Dec 6, 2:31 pm, "James Moore" wrote: > Is there a particular reason you're comparing to nil? Normally I'd just > write something like > > (@product_coverages && @product_coverages.length > 0) > > - James Moore