From: Martin DeMello Date: 2006-12-06T19:40:03+09:00 Subject: join_with While golfing with the hex_ip thread, I realised that map takes no argument, and join takes no block, leaving a vacuum for a combined method: module Enumerable def join_with(sep, &blk) map(&blk).join(sep) end end hex_ip.scan(/../).join_with('.') {|i| i.hex} join_with is still a little clunky - any better name? martin