From: sempsteen Date: 2006-11-26T06:53:52+09:00 Subject: Re: coding practise ok, i get it. so when we invoke Hash#has_key? it does not responde by calling and getting the result of Hash#[] method, like if [] responds nil has_key gives false. > It also allows for good code readability - 'has_key?': It's pretty > obvious to, e.g., a reviewer what the code wants to do. Yes, i agree with you and i also want to code in the same way. I want to learn the best way of doing this. Let's say that i want to learn the answer to the ultimate question of life, the universe and everything. i don't want to make two calls that first one returns true or false after 7.5 million years and second one returns the answer another 7.5 million years later if first one returns true. puts everything.answer if everything.has_answer?