From: Logan Capaldo Date: 2006-10-06T10:21:14+09:00 Subject: Re: append_features vs include On Fri, Oct 06, 2006 at 10:06:12AM +0900, Rob Sanheim wrote: > I've read somewhere that Module#append_features is the old name for > this method, and "included" should be used going forward. Makes sense > to me, as "included" is shorter and fits the method better, anyways. > > So is "append_features" going to be removed at some point, maybe 2.0? > I don't see it as really buying us anything, as its not a "humane" > alias like length vs size are for Array. > It's not an alias at all. (Hence why using append_features is that much more work than included) It's the method that does the actual appeneding of the features of the modules into the class or module that it gets included into. It is in other words, an implementation detail. included on the other hand is a callback that gets called after all this nitty gritty detail stuff is finished, for the express purpose of allowing custom code to be hooked into the inclusion process. > Rob > -- > http://www.robsanheim.com > http://www.seekingalpha.com > http://www.ajaxian.com