From: Charles O Nutter Date: 2006-10-03T05:17:50+09:00 Subject: Re: New magical version of Symbol.to_proc On 10/1/06, Dr Nic wrote: > Re: performance overhead - I'm not sure if the standard map+block is > more or less efficient than a for-loop, but I use it anyway because my > code is much more readable and writable. If I later discovered that I > had a performance bottleneck near my map+blocks, then I could refactor > them for speed. The JRuby code started out as a port of the C Ruby code, and for us a 'for' is just an 'each' over a range...so it's probably about the same, performance-wise. -- Contribute to RubySpec! @ www.headius.com/rubyspec Charles Oliver Nutter @ headius.blogspot.com Ruby User @ ruby.mn