From: Jason Nordwick Date: 2006-09-09T00:49:58+09:00 Subject: BEST alias_method Re: [CHALLENGE] better alias_method The best alias_method methods would be one that didn't exist. (1) It encourages breaking of naming conventions since at times two functions get defined, one with the convension and one without, (see hash.merge! and hash.update), and I really liked the convention where mutatations have bangs at the end. (2) This one function double the complexity of learning to read ruby. Now I don't just have to know what hash.update does, but also that hash.merge! is the same thing. And when individual developers start adding aliases to buildins things get ever worse. Array.lower isn't necessary when Array.first and Array[0] are both as short or shorter and just as descriptive. Alaises increase complexity and really are one of Ruby's biggest dislikes for me. -j