From: Tobias Reif Date: 2001-09-03T01:12:06+09:00 Subject: [ruby-talk:20709] Re: RCR: non-bang equivalent to []= Yukihiro Matsumoto wrote: > Since we have "slice" for non destructive "[]", I think it's OK to > have non destructive "[]=", if (and only if) we can define good name > for the operation. I don't feel good for either "set_at", "set_at!", > nor "at()=". David Black suggested: with_at(position,new_value) I think with_at(new_value,position) because of the sequence: 1.position: with new_value 2.position: at position More ideas for names: map_at, map_here, map_one, fill_at, place_at, value_at, replace_at, fill, change_at, change_item, change_element, new_at_index (all plus ! version) Tobi -- Tobias Reif http://www.pinkjuice.com/myDigitalProfile.xhtml go_to('www.ruby-lang.org').get(ruby).play.create.have_fun http://www.pinkjuice.com/ruby/