From: matz@... (Yukihiro Matsumoto) Date: 2001-09-03T00:51:50+09:00 Subject: [ruby-talk:20708] Re: RCR: non-bang equivalent to []= Hi, In message "[ruby-talk:20675] RCR: non-bang equivalent to []=" on 01/09/02, Tobias Reif writes: |I'm rying to modify specific items in a nested array, without modifying |the original. |I tried some variations, but most things that come to mind failed. |There are ways to achive what I want (I found some hack that works for me), |but I believe it would be good for the ease of use to introduce the |following: Since we have "slice" for non destructive "[]", I think it's OK to have non destructive "[]=", if (and only if) we can define good name for the operation. I don't feel good for either "set_at", "set_at!", nor "at()=". matz.