From: Daniel DeLorme Date: 2006-07-08T21:16:47+09:00 Subject: Re: About 1.9 #__method__ feature. transfire@gmail.com wrote: > object_id > object_class > object_send > > Then for the all methods that bypass access resitrictions: > > instance_send > instance_eval > instance_exec > instance_variable_get > instance_variable_set > instance_variables I agree with that proposal, and I think it underlines a fundamental dichotomy that I've been seeing in the discussion. Basically some people approach this as users; they want the names to reflect how the methods are used. And some people approach it as language designers; they want the names to reflect what is actually going on inside the interpreter. I think the first approach is the correct one; an interface is not supposed to reveal all the ugly or complicated or subtle details of the architecture within. Daniel