From: transfire@... Date: 2006-06-17T00:05:20+09:00 Subject: Re: Why the lack of mixing-in support for Class methods? Daniel Schierbeck wrote: > ara.t.howard@noaa.gov wrote: > >> If 'class_extension' affects modules as well, do you think of any more > >> generic name, in place of "class" extension? > > > > singleton_methods &block > > Except it's not restricted to methods. Here's a couple of spinoffs: > > * singleton_module > * singleton_extension > Eeek! Please, no "singleton". Anything but "singleton". T.