From: Daniel Schierbeck Date: 2006-06-16T23:38:32+09:00 Subject: Re: Why the lack of mixing-in support for Class methods? ara.t.howard@noaa.gov wrote: >> If 'class_extension' affects modules as well, do you think of any more >> generic name, in place of "class" extension? > > singleton_methods &block Except it's not restricted to methods. Here's a couple of spinoffs: * singleton_module * singleton_extension Cheers, Daniel