From: Yukihiro Matsumoto Date: 2006-06-15T17:55:41+09:00 Subject: Re: A plan for another unicode string hack Hi, In message "Re: A plan for another unicode string hack" on Thu, 15 Jun 2006 17:08:41 +0900, "Leslie Viljoen" writes: |I agree with Austin on this - the distinction is too vague. I'd leave |length and size the same and make a size_in_bytes method. On my latest prototype (not checked in anywhere), String#length and String#size behave same, and there is String#buffer_size to return size in bytes. The method name might change in the future. matz.