From: James Edward Gray II Date: 2006-06-05T23:57:08+09:00 Subject: Re: New webserver On Jun 5, 2006, at 9:45 AM, Stuart Brand wrote: > Thanks all, this worked fine > > def self.path(path) > fileLine = path[1].strip > fileLine = fileLine.gsub(/\.\//, '') > fileLine = fileLine.gsub(/\/\./, '') > fileLine = fileLine.gsub(/\\/, '') > fileLine = fileLine.gsub(/\.{2,}/, '') > fileLine = fileLine.gsub(/\/{2,}/, '') > fileLine = "/srv/www/htdocs/" + fileLine > return fileLine > end > > Is there a way of making it look prettier? Perhaps: def self.path(path) path.first.strip. gusb(...). gsub(...). ... end Again, Ruby naming conventions are file_line, not fileLine. Have to start adopting typical Ruby style so you can get Rubyists interested in your web server. James Edward Gray II