From: Robert Klemme Date: 2006-05-22T19:15:17+09:00 Subject: Re: rubynuby - confused by method name "inject" 2006/5/22, Regg Mr : > Seems like "sum" would have been a better name. Definitively not because you can do far more than calculating sums with inject. > Also > > [1,2,3].each {|a| b += a} > > is easier to read ...for me. Yes, but it also needs more LOC. robert -- Have a look: http://www.flickr.com/photos/fussel-foto/