From: Daniel Schierbeck Date: 2006-05-21T18:46:57+09:00 Subject: Re: rubynuby - confused by method name "inject" Jeff Pritchard wrote: > If anybody wants to take a stab at "collect", that would be welcome I think #collect is fairly intuitive: addresses = contacts.collect{|contact| contact.address} Here we collect the addresses of the contacts. Daniel