From: Jeff Pritchard Date: 2006-05-21T14:17:27+09:00 Subject: Re: rubynuby - confused by method name "inject" BTW, I think "combine" makes the most sense to me for a synonym of "inject". The block describes how to combine all of the elements into a single answer. vis: total_cost = [[pie,2.00],[coffee,1.00]].combine { |cost, [food, price]| cost += price } jp -- Posted via http://www.ruby-forum.com/.