From: Daryl Richter Date: 2006-05-12T01:07:51+09:00 Subject: Re: A major ruby annoyance! On May 9, 2006, at 9:14 AM, M. Edward (Ed) Borasky wrote: > > > Edgardo Hames wrote: >> In Ruby, the naming convention states that you should use CamelCase >> for classes and snake_case for method or variables, why would you >> then >> confuse when to use an "a" or and "A"? > 1. Is that a Ruby naming convention or a Rails naming convention? > 2. If CamelCase comes from Perl and snake_case comes from Python, what > do you call this convention: makeNextRecord? that's smalltalkMethodCase: ;) > 3. Should the Ruby conventions be called PickaxeCase? gem_case? > > > > Yes ... I'm bored ... I should be programming ... back to it now? > > -- > M. Edward (Ed) Borasky > > http://linuxcapacityplanning.com > > -- Daryl "Stress rarely has a positive impact on our ability to think. Never, I'd guess." -- Ron Jeffries, 2005