From: James Edward Gray II Date: 2006-05-09T22:22:29+09:00 Subject: Re: A major ruby annoyance! On May 9, 2006, at 8:14 AM, M. Edward (Ed) Borasky wrote: > Edgardo Hames wrote: >> In Ruby, the naming convention states that you should use CamelCase >> for classes and snake_case for method or variables, why would you >> then >> confuse when to use an "a" or and "A"? > 1. Is that a Ruby naming convention or a Rails naming convention? Ruby and even partially encouraged by the interpreter, since constants are expected to begin with a capital letter. James Edward Gray II