From: "M. Edward (Ed) Borasky" Date: 2006-05-09T22:14:01+09:00 Subject: Re: A major ruby annoyance! Edgardo Hames wrote: > In Ruby, the naming convention states that you should use CamelCase > for classes and snake_case for method or variables, why would you then > confuse when to use an "a" or and "A"? 1. Is that a Ruby naming convention or a Rails naming convention? 2. If CamelCase comes from Perl and snake_case comes from Python, what do you call this convention: makeNextRecord? 3. Should the Ruby conventions be called PickaxeCase? gem_case? Yes ... I'm bored ... I should be programming ... back to it now? -- M. Edward (Ed) Borasky http://linuxcapacityplanning.com