From: Pistos Christou Date: 2006-05-02T01:31:57+09:00 Subject: Re: More explicit Ruby code Brad wrote: > Kernel.puts("Print this string") > > instead of this: > > puts "Print this string" I personally would never put Kernel in front there. If I'm going to qualify puts, it would be to specify the actual thing doing the putting (or "receiving" the putting, heh), such as $stderr.puts or my_opened_file.puts. I think putting Kernel in front draws attention to something that ought to be left in the background. It might be akin to seeing all the [serif construction lines][1] for every letter in text. It also smacks of a lingering attachment to System.out.println. ;) My personal style with parentheses is to omit them only with visually-single arguments. In style choices like these, I always try to aim for clarity, rather than stick to a rule in all cases. [1]: http://www.dailyllama.com/news/2002/images/time_bandits_2.jpg -- Posted via http://www.ruby-forum.com/.