From: James Edward Gray II Date: 2006-04-06T01:57:31+09:00 Subject: Re: Comparing Arrays On Apr 5, 2006, at 11:44 AM, Nathan Olberding wrote: > I have two arrays: originalList and deleteList. Just FYI, the Ruby naming convention is to make those original_list and delete_list. > I'm trying to iterate > through original list and remove each item if it appears in the > deleteList. Simple enough. Sure is, try: original_list - delete_list ;) James Edward Gray II