From: Bret Pettichord Date: 2006-03-29T14:33:41+09:00 Subject: Re: strings and ruby style? I like your "current thinking". I also think that the code is easier to read if it consistently uses either one approach or the other. This rule itself ends up favoring your second example over the first. Bret ==== $ie.text_field(args[0], $test_data[args[1].to_s]["#{args[2]}_fld"]).value=$test_data[args[1].to_s][args[2].to_s] $ie.text_field(args[0], $test_data["#{args[1]}"]["#{args[2]}_fld"]).value=$test_data["#{args[1]}"]["#{args[2]}"]