From: misiek Date: 2006-02-17T07:18:30+09:00 Subject: Re: Rails application failed to start properly > .httaccess > RewriteRule ^(.*)$ dispatch.fcgi?$1 [QSA,L] > > /etc/conf/apache2 > APACHE2_OPTS="-D DEFAULT_VHOST -D FASTCGI -D SSL -D PHP4" > > > on localhost works good when I copy on server with real domain does not > work the message like in subject. > > in apache.log i got > [Thu Feb 16 16:11:51 2006] [error] [client 192.168.10.101] mod_rewrite: > maximum number of internal redirects reached. Assuming configuration > error. Use 'RewriteOptions MaxRedirects' to increase the limit if > neccessary. > > but what it does mean ? > > what is wrong ? ok I del $1 option from .htaccess RewriteRule ^(.*)$ dispatch.fcgi?$1 [QSA,L] ^ no when I start the web site I got with my browser that message #!/usr/bin/ruby18 # # You may specify the path to the FastCGI crash log (a log of unhandled # exceptions which forced the FastCGI instance to exit, great for debugging) # and the number of requests to process before running garbage collection. # # By default, the FastCGI crash log is RAILS_ROOT/log/fastcgi.crash.log # and the GC period is nil (turned off). A reasonable number of requests # could range from 10-100 depending on the memory footprint of your app. # # Example: # # Default log path, normal GC behavior. # RailsFCGIHandler.process! # # # Default log path, 50 requests between GC. # RailsFCGIHandler.process! nil, 50 # # # Custom log path, normal GC behavior. # RailsFCGIHandler.process! '/var/log/myapp_fcgi_crash.log' # require File.dirname(__FILE__) + "/../config/environment" require 'fcgi_handler' RailsFCGIHandler.process!